www.5129.net > projECt FACEt JAvA vErsion 6.0 is not supportED.

projECt FACEt JAvA vErsion 6.0 is not supportED.

项目从其它的电脑中拷贝过来后,然后进行导入到自己的eclipse中就会提示为Project facet Java version 1.8 not supported的问题,这个是java版本不兼容的问题,可以按照以下步骤进行设置和调整。 1.其它的项目到自己的eclipse中后,进行运行项目...

在工程目录下的.settings文件夹里,打开org.eclipse.wst.common.project.facet.core.xml文件,其内容是: 删除几行,只留下面三行就行

发生这个问题的原因是你的java编译环境(JDK版本),与tomcat运行环境(JDK或JRE版本)不一致导致的。从你给的图看出,应该是Java编译环境是JDK1.8,而tomcat运行环境是1.7导致的。

在工程目录下有一个.settings文件夹,打开org.eclipse.wst.common.project.facet.core.xml做如下修改:

除了web.xml中的vision以外,还有 .setting文件夹内的org.eclipse.wst.common.project.facet.core.xml文件

web.xml里面的。xml头的版本号和你项目的不facets的不匹配。应该是xml的高了。。facets里面低了。去project properties里面修改,有一个选项Danymic web module 后边是version,你修改下应该就好了。

项目执行方面的java没能被发现。功能将是有限的

网站地图

All rights reserved Powered by www.5129.net

copyright ©right 2010-2021。
www.5129.net内容来自网络,如有侵犯请联系客服。zhit325@qq.com